Main Region

grid combo headers missing after upgrading apex to 5.1 and foex to 3.0.1.3254
| | 3 answers | 15 views

GP
Posted by gp999
Sep 19th, 2017 at 21:55
0

using grid combo and after upgrading apex from 5.04 to 5.1 and foex 2.2 to 3.0.1, the grid column headers do not show and behind the grid data bleeds thru. grid comb lov does not work in any of our updated apex.

1 Comment

GP
gp999 on Sep 20th, 2017 at 14:38

dont know how to replicate the fact we upgraded the foex app from apex 5.01 to 5.1 and foex from 2.2 to 3.0.1. PLuse I have data unique to our company. This is a app that worked fine until we did the update. All our existing combo grids are missing column headers. Any new apps, the combo grid displays properly.

Profile Image
Posted by FOEX-SUPPORT
Sep 20th, 2017 at 06:48
0

Can you please create a test case on trial.tryfoexnow.com and also include a screenshot for reference so we can see the problem you are trying to explain.

Also please report the browsers and versions affected by this issue and what FOEX theme you are using (Shared Components -> Component Settings -> FOEX Application Settings)

Thank you

0 Comments

Profile Image
Posted by FOEX-SUPPORT
Sep 22nd, 2017 at 12:56
0

We have not seen this behaviour in our upgrade tests. That said, If all new grid combo's display correctly then there must be a slight difference in the settings, between these and grid combo's built using FOEX 2.2.x.

Can you please advise us what your "Match Field Width" setting is and "Grid Custom Config" value is for a grid combo that works, and the values for one that does not e.g.

alt text

We suspect that this is caused by and issue with the height setting. Can you confirm if there is a height setting in the combo? We suggest that a "maxHeight": xxx is also added.

0 Comments

GP
Posted by gp999
Sep 26th, 2017 at 16:11
0

our setting is the following.

It looks like most of the issue was cache related. Once I changed any of the below settings just for one of the combo gids, all the rest got refreshed and started to work. We had around 10 grid combos. All of them did not show the column headers. I updated any setting on the first combo grid then all rest started working.

thanks for your support.. our typical setting... { "matchFieldWidth":true, "width": 1100, "height": 600, "apexPageSize":10, "forceFit": true, "showRowNumbers": true, "focusOnSearch": true }

0 Comments

You must log in or sign up to post questions and answers.