I'm assessing some issues with a client that recently upgraded from apex 4 to apex 5.1

The apps appear to not be affected as they seem to function w/out issue, however, the FDA has stopped working. I applied the recommended FDA instructions to correct it with out success.

I suspect they are simply in need of upgrading to a version of FOEX that better supports APEX 5.1. I did attempt to run the foex_upgrade_apex_installation.sql script for the 2.2.0 plugin but it appears to not support past apex 5.0.x

Below is the list of FOEX versions currently in use, all were installed prior to the APEX 5 upgrade, can you direct me on what actions I need to take to get these apps inline with APEX 5.1? Is the Apex upgrade affecting the FDA? V1.2.2 V2.0.0 V2.1.0 V2.2.0

asked 06 Oct, 13:11

Jason's gravatar image

Jason
12
accept rate: 0%


APEX 5.1 is only supported for 3.x and v2.2.1+. You can download them from the support portal: https://support.tryfoexnow.com

If you continue to have problems please attach a number of images describing the issue, and any errors you encounter. Plus please report the version by clicking on the FOEX icon in the top right corner of the builder and clicking on "About the FDA"

alt text

link

answered 09 Oct, 02:44

FOEX-SUPPORT's gravatar image

FOEX-SUPPORT
4.6k15
accept rate: 32%

Something Odd I just came across, when I go to Shared Components/Component Settings, the only FOEX entry is "FOEX Application Settings(Plug-In)". The template app has 55 entries.

(12 Oct, 09:21) Jason Jason's gravatar image

I made a copy of the app (10600) and tried to re-install the plugins. i.e. SQL> @load_all_plugins_into_app_id.sql 10600

This is the tail of the output

--application/end_environment ...done old 2: FX_P_PLUGIN_INIT.synchronize_component_settings(&1); new 2: FX_P_PLUGIN_INIT.synchronize_component_settings(10600); FX_P_PLUGIN_INIT.synchronize_component_settings(10600); * ERROR at line 2: ORA-06550: line 2, column 22: PLS-00302: component 'SYNCHRONIZE_COMPONENT_SETTINGS' must be declared ORA-06550: line 2, column 5: PL/SQL: Statement ignored

(12 Oct, 09:54) Jason Jason's gravatar image

Please make sure you do this within the application parsing schema which should have the local synonyms that point to v3.0.1, otherwise if you install say as SYS/SYSTEM then it will use public synonyms, which judging by the error is an old version of FOEX

(12 Oct, 09:57) FOEX-SUPPORT FOEX-SUPPORT's gravatar image

I got past this by first running: alter session set current_schema=FOEX_030001;

FDA still complains, and there's still only one entry in the Component Settings view.

Edited: actually the Component settings looks good now, however the FDA not so much.

(12 Oct, 10:32) Jason Jason's gravatar image

No that is not correct the plugins should be loaded into an application using your application parsing schema not the FOEX schema.

(12 Oct, 10:45) FOEX-SUPPORT FOEX-SUPPORT's gravatar image

No, I ran it as sys. I just did it again as you suggested (via parsing schema), restarted bowser, still complains and wants me to run FX_P_DEVELOPER_ADDON.Check_Preconditions(10600), ran as parsing schema from SQL workshop as instructed, FDA still wont activate.

(12 Oct, 10:52) Jason Jason's gravatar image
showing 5 of 6 show all

I'm still having trouble getting the FDA activated.

The original installed FOEX version was V2.2.0, for our app 106. I installed V3.0.1, w/out public grant/synonyms We use multi-version FOEX so I also ran the grant/private synonym script for the parsing schema. I installed the plugins into our application (106). The FDA still complains. Running this did not help: FX_P_DEVELOPER_ADDON.Check_Preconditions(106) I then installed the template app into the same parsing schema and it has no issues. I reviewed the shared components/plugins from both apps, nothing noticeably different/missing. The version in app 106 does report 3.0.1 from the plugin settings.

About FDA (from our app 106) FDA Version 3.0.0.23 Revision $Rev: 7289 $ Image Path /i/ APEX Version 513

About FDA (from FOEX Template Application - Theme 42 shipped with V3.0.1) FDA Version 3.0.0.23 Revision $Rev: 7289 $ FOEX Plugin Main Release V3.0.1 FOEX Plugin Version V3.0.1 FOEX DB Version 7170 Image Path /i/foex/ APEX Version 513

link

answered 12 Oct, 09:11

Jason's gravatar image

Jason
12
accept rate: 0%

Which browser is that? Did you try restarting the browser? Another thing you can try in App 106 is starting the "Enable FOEX Plugin Enhancements", then reload the page and try "Enable Plugin Enhancements" again.

(12 Oct, 09:42) FOEX-SUPPORT FOEX-SUPPORT's gravatar image

I'm using firefox, I restarted and tried in a private instance. enable plugin complains and tells me to: Execute FX_P_DEVELOPER_ADDON.Check_Preconditions(10600), that doesn't help.

(12 Oct, 10:43) Jason Jason's gravatar image

Same issue in Chrome, this works in the Foex template App so shouldn't be a browser issue...

(12 Oct, 10:44) Jason Jason's gravatar image

Do you have this page ID in your app? 9906150524

And can you make sure that under "Security Attributes" -> "Runtime API Usage" = "Modify this application"

(12 Oct, 14:16) FOEX-SUPPORT FOEX-SUPPORT's gravatar image

Yes, to both questions.

(12 Oct, 15:12) Jason Jason's gravatar image

Can you please check the network tab in developer tools for the AJAX response when activating the FDA.

Also please clear local storage since there might be an invalid cached setting.

(13 Oct, 08:58) FOEX-SUPPORT FOEX-SUPPORT's gravatar image

any other suggestions or information I can provide?

(13 Oct, 12:27) Jason Jason's gravatar image

Monitoring Network when clicking the Enable FOEX plugins reports a 200 Status for wwv_flow.show

(13 Oct, 17:39) Jason Jason's gravatar image

Cleared local storage... no help.

(13 Oct, 17:44) Jason Jason's gravatar image

What is the actual response text of the AJAX call that you said you got a 200 status for? i.e. when activating the FDA

(2 days ago) FOEX-SUPPORT FOEX-SUPPORT's gravatar image

Request header: Host: 10.43.135.135 User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0 Accept: text/html, /; q=0.01 Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate, br Referer: https://10.43.135.135/odsdev3/f?p=4000:1:113910808506719::NO:RP:FB_FLOW_ID,F4000_P1_FLOW,P0_FLOWPAGE,RECENT_PAGES:10600,10600,10600 Content-Type: application/x-www-form-urlencoded; charset=UTF-8

(yesterday) Jason Jason's gravatar image

Response header: Date: Tue, 17 Oct 2017 15:23:24 GMT Content-Type: text/html;charset=UTF-8 X-UA-Compatible: IE=edge Connection: close Transfer-Encoding: chunked

(yesterday) Jason Jason's gravatar image

the response it too big to paste here. below is a link to a shared document that has the full text;

https://1drv.ms/t/s!ArBVmXsxBG72gYxO0kfQ8MugA9-tBQ

(yesterday) Jason Jason's gravatar image

We can see that the response is HTML and not JSON and means the call is running into an APEX exception. The APEX engine throwing up an error: "Your session has expired"

Would you be able to attend a web meeting? and if so what is your timezone? if it is GMT-5 or thereabouts we would like to schedule a morning meeting (your time) e.g. between 9am and 10am

(yesterday) FOEX-SUPPORT FOEX-SUPPORT's gravatar image

sounds good, 9-10 GMT works... ready whenever you are.

(16 hours ago) Jason Jason's gravatar image
showing 5 of 15 show all
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1

Asked: 06 Oct, 13:11

Seen: 383 times

Last updated: 16 hours ago

FOEX Links

Related questions